Vlan là gì – Một số câu lệnh cấu hình vlan cơ bản

Phan Thái Châu

15/11/2020

Share

Vlan là gì

Có những loại VLAN nào, kể tên các loại Vlan 

Một trong những khái niệm mà nhiều bạn nhầm lẫn khi học mạng, quản trị mạng thường gặp. Đó chính là Có những loại VLAN nào ? Native vlan là gì ? Bài viết này Kho phần mềm Soft Folder sẽ giải đáp thắc mắc đó cho các bạn ! Hãy tìm hiểu trong bài viết sau !

Khái niệm Vlan là gì

Có 2 cách nhìn về VLAN

Nhìn trên một Switch

VLAN là một switch logical (ta có ổ cứng 80GB vật lý chia thành ổ C, D, E. Các ổ logical này là độc lập). Các VLAN độc lập sẽ không Forwarding sang VLAN khác. VLAN sẽ không có bảng MAC của riêng nó mà nó sử dụng chung bảng MAC của Switch vật lý. Switch vật lý sẽ xây dựng bảng MAC như sau:

VLAN MAC Cổng VLAN MAC Cổng VLAN MAC Cổng
1 00.0c.0a F0/1 2 00.0c.0n F0/11 3 00.0c.n1 F0/16
1 00.0c.05 F0/2 2 00.0b.0d F0/12 3 00.0c.n2 F0/17
1 00.0c.09 F0/3 2 00.0c.06 F0/13 3 00.0c.n3 F0/18
1 00.0c.00 F0/4 2 00.0c.08 F0/14 3 00.0c.n4 F0/19

Trên một Switch vật lý chia thành 3 VLAN là VLAN 1, VLAN 2, VLAN 3. Sau khi chia thì 3 VLAN sẽ tương ứng là 3 Switch độc lập. Trên một Switch 24 cổng ta có VLAN 1 có cổng từ 1-10, VLAN 2 có cổng từ 11-15, VLAN 3 có cổng từ 16-24. Các máy ở VLAN 1 sẽ không trao đổi được với các máy ở VLAN 3 vì 2 VLAN này tương ứng 2 Switch độc lập.

Vlan là gì
Vlan là gì – Khái niệm Vlan

+ Nhìn trên cả một hệ thống: VLAN là một Boroadcast domain.

Xét trên 2 Switch vật lý:

+ Mỗi Switch chia thành 3 VLAN giống nhau. Nguyên tắc là VLAN 1 của SW1 thông VLAN 1 của SW2, VLAN 2 của SW1 thông VLAN 2 của SW2, VLAN 3 thông VLAN 3.

SW1 SW2
VLAN1 VLAN1
VLAN2 VLAN2
VLAN3 VLAN3

+ Để VLAN 1 thông với nhau thì trên SW1 cắm dây vào một cổng VLAN 1 kết nối sang cổng thuộc VLAN 1 của SW2, tương tự với VLAN2 và 3.

+ Mỗi VLAN sẽ tương ứng một mạng độc lập nên gọi là một Broadcast domain.

Tại sao phải chia VLAN (Virtual Local Area Network)

Xét hệ thống bình thường

Một Công ty giáo dục thuê một tòa nhà có nhiều tầng. Tầng 1 là khối văn phòng có 1 Switch (đây gọi là mạng LAN khối văn phòng bao gồm cả nhân viên tư vấn). Tầng 2  là phòng giám đốc đặt một Switch, Tầng 3 giảng viên đặt một Switch, tầng 4, 5 là của sinh viên. Tất cả các tầng đều nối ra Router và ra internet. Nhưng vào mùa tuyển sinh thì số lớp sẽ ít nhưng tư vấn viên cần nhiều (khối văn phòng chuyển lên một ít ở tầng 4 và 5).

Phòng giám đốc cần thu hẹp lại để nhường phòng khác, nhưng phòng ban giám đốc lại chỉ có 3 hoặc 4 người thì thừa ra rất nhiều cổng. Hệ thống sẽ có sự tốn kém khi có thiết bị thay đổi.

Do cả tòa nhà cùng Router và đi ra internet nên cùng dùng một dải mạng, cùng một Broadcast domain. Hệ thống sẽ không có độ bảo mật cao giữa các phòng ban. Khi bị Virus thì cả hệ thống có thể bị lây lan. Khi có một người đứng trong mạng có thể bắt được hết tất cả gói tin toàn mạng đi qua Router.

Trong một doanh nghiệp có sử dụng nhiều thành phần và ứng dụng vào hệ thống mạng như: dùng Voice IP, truy cập Web, Mail, truy cập dữ liệu trong hệ thống. Nếu bình thường thì không sao nhưng không may bị tắc nghẽn thì sẽ lỗi cả hệ thống.

Vì sao cần phải chia Vlan
Vì sao cần phải chia Vlan

Xét hệ thống có thiết bị hỗ trợ VLAN

Vẫn các Switch như vậy nhưng khi dùng VLAN nó chỉ cần kéo một dây từ Router về một Switch nào đó, sau đó sẽ chia VLAN

Trên một Switch 24 cổng nếu hỗ trợ VLAN thì nó sẽ chia nhỏ khu vực một cách hợp lý: VLAN 1 có cổng từ 1-10, VLAN 2 có cổng từ 11-15, VLAN 3 có cổng từ 16-24.

Chú ý: Cisco 2900 hỗ trợ 64 VLAN, 2950 hỗ trợ 255 VLAN, 4500 hỗ trợ 4000 VLAN.

Có các loại Vlan nào 

VLAN 1 là gì

Đây là kiểu mạng mặc định của tất tất cả các thiết bị chuyển mạch hỗ trợ VLAN và nó hoạt động ở Lớp 2 (Data Link layer) trong mô hình OSI của hệ thống. Vì vậy nếu hệ thống mạng máy tính của bạn được trang bị một thiết bị chuyển mạch có hỗ trợ chức năng này mà bạn chưa thiết lập các thông số kỹ thuật thì mặc định nó vẫn có thể chuyển tiếp các gói dữ liệu giữa các máy tính và thiết bị kết nối vào nó một cách bình thường như các thiết bị chuyển mạch khác. Vì lúc này tất cả các cổng mạng trên thiết bị chuyển mạch mặc định đều nằm trong cùng một miền quảng bá và với sự quản lý của VLAN 1.

Trong VLAN 1 có rất nhiều giao thức ở Lớp 2 hoạt động giao tiếp với nhau như: CDP, PagP, VTP; nên đây chính là lý do tại sao VLAN 1 được chọn làm kiểu mạng mặc định và rất dễ thấy trên các thiết bị mạng có hỗ trợ tính năng chia mạng ảo của Cisco System.

Default VLAN là gì

Là kiểu VLAN mặc định ban đầu với tất cả các cổng giao tiếp trên thiết bị chuyển mạch. Vì vậy Default VLAN cũng có thể hiểu là VLAN 1, và các VLAN khác như User VLAN, Native VLAN, Management VLAN đều là các thành phần con của Default VLAN.

User VLAN (hay Data VLAN) 

Là VLAN trong đó chứa các tài khoản người dùng thành từng nhóm dựa theo các thuộc tính về đặc thù công việc của từng nhóm làm việc hay theo thuộc tính về vị trí vật lý của các nhóm làm việc này.

Native VLAN là gì 

Native VLAN là một VLAN được sử dụng để cấu hình Trunking do một số thiết bị không tương thích với nhau. Khi một cổng của switch được cấu hình trunk, trong phần tag của frame đi qua cổng đó sẽ được thêm một số hiệu VLAN thích hợp.

Tất cả các frames thuộc các VLAN khi đi qua đường trunk sẽ được gắn thêm các tag của giao thức 802.1q và ISL, ngoại trừ các frame của VLAN 1. Như vậy, theo mặc định các frames của VLAN 1 khi đi qua đường trunk sẽ không được gắn tag.

Khả năng này cho phép các cổng hiểu 802.1Q giao tiếp được với các cổng cũ không hiểu 802.1Q bằng cách gửi và nhận trực tiếp các luồng dữ liệu không được gắn tag. Tuy nhiên, trong tất cả các trường hợp khác, điều này lại gây bất lợi, bởi vì các gói tin liên quan đến native VLAN sẽ bị mất tag.

Native VLAN có thể được chuyển thành VLAN khác bằng câu lệnh như sau :

Switch(config-if)#switchport trunk native vlan vlan-id

Lưu ý : đối với Native VLAN chúng ta không nên sử dụng như là user VLAN hay management VLAN.

Management VLAN là gì

Để có thể giám sát từ xa các thiết bị chuyển mạch trong hệ thống mạng của mình, bạn cần phải có một VLAN đặc biệt dùng để thực hiện việc này, đó chính là Management VLAN. Bằng cách gán một địa chỉ IP dùng để telnet từ xa vào hệ thống mạng thông qua địa chỉ IP này, và có thể cấm các người dùng khác truy cập vào thiết bị.

Vì đây là một VLAN khá nhạy cảm được cấp một số quyền quản trị nên nó cần phải được tách riêng ra khỏi các VLAN khác để đảm bảo yếu tố an toàn bảo mật. Khi mạng có vấn đề như: hội tụ với STP, broadcast storms thì một Management VLAN cho phép nhà quản trị vẫn có thể truy cập được vào thiết bị và giải quyết vấn đề đó.

Cấu hình địa chỉ IP cho Switch

Switch#config terminal

Switch(config)#interface vlan vlan-id

Switch(config-if)#ip address xxx.xxx.xxx.xxx subnet mask

Switch(config-if)#end

Địa chỉ này sẽ được sử dụng để quản trị Switch từ xa (qua telnet). xxx.xxx.xxx.xxx là địa chỉ IP của VLAN. Ví dụ: 192.168.10.2 Ví dụ subnet mask là 255.255.255.0

Voice VLAN là gì

Voice VLAN là VLAN dành cho lưu lượng thoại. Nó cho phép các cổng Switch mang lưu lượng thoại IP từ một điện thoại IP. Người quản trị mạng cấu hình một Voice VLAN và gán nó để truy cập các cổng. Khi một điện thoại IP được kết nối với các cổng Switch, Switch sẽ gửi gói tin CDP đó hướng dẫn các điện thoại IP đính kèm để gửi lưu lượng thoại được gán nhãn VLAN ID.

Một số câu lệnh cấu hình VLAN thường gặp

Câu lệnh đặt tên cho VLAN

SW(config)# Vlan 2

SW(config-vlan)# name IT

SW(config-vlan)# exit

Câu lệnh gán cổng cho VLAN

SW(config)# interface  range  f0/1-5

SW(config-if-range)#switchport access  vlan 2

Cậu lệnh Gán Trunking cho cổng

+ Đối với dòng 2900 nó hỗ trợ sẵn dot1Q nên không cần bật. Chỉ cần vào cổng bật Trunk lên là xong

SW(config)# interface f0/24

SW(config-if)#switchport mode trunk

+ Đối với dòng 3500 trở lên phải vào bật dot1Q hay ISL nó mới chạy. Nếu không bật sẽ báo lỗi:

SW(config)# interface f0/24

SW(config-if)#switchport trunk encapsulation [dot1Q hay ISL]

SW(config-if)#switchport mode trunk

Chú ý: thường gán cổng trunk chạy sang Switch khác hoặc về Router.

Câu lệnh Gán Native VLAN vào VLAN quản lý

SW(config)# Vlan 100

SW(config-vlan)# name Managerment

SW(config-vlan)# exit

SW(config)# interface f0/24 (phải có 2 lệnh)

SW(config-if)#switchport access vlan 100

SW(config-if)#switchport native vlan 100

SW(config-if)#exit

SW(config)#interface vlan 100

SW(config-if)#ip add 192.168.1.1 255.255.255.0

Cấu hình trên thực tế về VLAN1, VLAN NATIVE, VLAN DEFAULT trên cùng VLAN1

SW0(config)#interface vlan 1

SW0(config-if)#ip add 11.0.0.254 255.255.255.0

SW0(config-if)#no shut

SW0(config-if)#exit

SW1(config)#interface vlan 1

SW0(config-if)#ip add 11.0.0.253 255.255.255.0

SW0(config-if)#no shut

SW0(config-if)#exit

CORE(config)#interface f0/0.1

CORE(config-subif)#encapsulation dot1Q 1

CORE(config-subif)#ip add 11.0.0.1 255.255.255.0

CORE(config-subif)#exit

Trên tất cả các thiết bị đều phải đặt mật khẩu

SW(config)#line console 0

SW(config-line)#password abc

SW(config-line)#login

SW(config-line)#exit

SW(config)#line vty 0 4

SW(config-line)#password abc

SW(config-line)#login

SW(config-line)#exit

SW(config)#enable secret cisco

Trên PC dùng lệnh: telnet 11.0.0.x để truy cập từ xa

Các lệnh kiểm tra vlan thường gặp

SW(config)# Show vlan

SW(config)# Show vlan brief

SW(config)# Show interfaces trunk

SW(config)# Show mac-address-table

chú ý: file cấu hình VLAN đặt trong bộ nhớ flash là: vlan.dad. Không lưu trong file Running config